Descope - High error rate on Management API calls โ€“ Incident details

High error rate on Management API calls

Resolved
Partial outage 50 %
Started 29 days agoLasted 15 minutes

Affected

US ๐Ÿ‡บ๐Ÿ‡ธ

Partial outage from 10:00 PM to 10:15 PM

API

Partial outage from 10:00 PM to 10:15 PM

EU ๐Ÿ‡ช๐Ÿ‡บ

Partial outage from 10:00 PM to 10:15 PM

API

Partial outage from 10:00 PM to 10:15 PM

Updates
  • Postmortem
    Postmortem

    The incident was caused by a regression in the middleware layer responsible for header parsing. The logic error prevented the middleware from correctly validating standard request headers, leading to a surge in 400 Bad Request responses.

    Full RCA will be delivered upon request, reach out to support for that.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.