Scheduled for July 27, 2025 at 8:00 AM โย 9:00 AM
Affects
US ๐บ๐ธ
Under maintenance from 8:00 AM to 9:00 AM
API
Under maintenance from 8:00 AM to 9:00 AM
EU ๐ช๐บ
Under maintenance from 8:00 AM to 9:00 AM
Completed
July 27, 2025 at 9:00 AMCompleted
July 27, 2025 at 9:00 AMMaintenance has completed successfully
In progress
July 27, 2025 at 8:00 AMIn progress
July 27, 2025 at 8:00 AMMaintenance is now in progress
Planned
July 27, 2025 at 8:00 AMPlanned
July 27, 2025 at 8:00 AMWe will be performing routine maintenance on our infrastructure during this window. While we do not anticipate significant disruptions, there may be occasional delays in processing audit and outbound related tasks.
We appreciate your understanding and will work to minimize any impact. If you have any concerns, please feel free to reach out to our support team.